Wednesday, December 30, 2020

RVM Contribution of Command Aliases

 Just a quick note that I got an RVM (Ruby enVironment Manager) contribution accepted:

  • Alias `rvm delete` as `rvm remove`
  • Alias `rvm gemset remove` as `rvm gemset delete`
  • Alias `rvm gemset move` as `rvm gemset rename`

As for the back story, I got tired of having to remember that to remove a Ruby, I gotta use "rvm remove", and yet to remove a Gemset, "rvm gemset remove" fails, and I gotta use "rvm gemset delete" instead (and vice versa). So, I followed the Ruby principle of "more ways than one" to accomplish a task (e.g. `Array#size`, `Array#length`, & `Array#count`), and added both "delete" and "remove" as options for both Rubies and Gemsets. I also had a similar confusion with "rvm gemset move" and "rvm gemset rename" because I'm used to "move" from Git, so I fixed it by adding a "move" alias for RVM Gemsets as well.


No comments: